Life After Applying

From Pokemorph MUSH Wiki
Jump to: navigation, search

This is a guide of frequently asked questions almost every player of Pokemorph MUSH wonders about after getting accepted as a player. Here we cover everything from how to ask for roleplay to how to ask for roleplay. A full list of commands can be found on the MUSH Commands page and more about MUSH protocol can be found on the MUSH Etiquette page.


Starting at the Beginning

Main article: Starting at the Beginning

We also have a guide that can be read before this one that is solely designed for first-time players of Pokemorph MUSH and the questions they immediately wonder about. This guide covers what a Pokemorph is, what a MUSH is, how to connect, how to get a character, and when applications are responded to.

Adding Your Characters to Your Client

After you have been approved and your character's password has been sent to you in the reply to your application, you'll need to add that character to your client's "worlds".

On PotatoMU

  1. Create a Pokemorph MUSH world by following the instructions in Logging On With Potato MU, if you haven't already done so.
  2. Click on "File"->"Connect to..."->"Pokemorph MUSH" (or whatever you called it).
  3. Click on "Options", then click "Configure World". The Configuration Options window will then appear.
  4. Click on "Characters" in the tree on the left, then click the "Add Character" button.
  5. Enter your character's name and password in text boxes, and then click the Save button, and then click the OK button.

Now you will be able to connect as that character after starting PotatoMU by clicking "File"->"Connect to..."->"Pokemorph MUSH", and then your character's name (such as "File->"Connect to..."->"Pokemorph MUSH"->"Rocky"). This is much more convenient than having to enter something like "connect Rocky <password>" every time you connect to the mush, and allows you to be logged on as more than one character at once if you have more than one character.

On MUSHclient

Easiest Method

  1. Create a Pokemorph MUSH world by following the instructions in Logging On With MUSHclient, if you haven't already done so.
  2. Start up MUSHclient, then click "File", then "Open World...", and then open the "PokemorphMUSH.mcl" file (or whatever you called the file). If it automatically connected, disconnect by clicking "Connection", then "Disconnect".
  3. Click "File", then "World Properties...", which will open the Configuration window.
  4. Click the IP Address leaf under the General branch in the tree menu on the left, and then change the World Name to something involving your character's name, such as "PMM Rocky".
  5. Click the Connection leaf under the General branch in the tree menu on the left, and then enter your character's Name and Password and select "MUSH/MOO (CONNECT name password)" from the Connect drop down menu.
  6. Click the "OK" button to close the Configuration window.
  7. Click "File", then "Save World Details As...", which will open a prompt to create a new world file. Give this file a name involving your character's name, such as "PMM_Rocky", and then click Save the world file.

Alternate Method

  1. Create a Pokemorph MUSH world by following the instructions in Logging On With MUSHclient, if you haven't already done so.
  2. Navigate to the folder you set to contain your worlds in Global Preferences (Step 2 in the above instructions), and copy the "PokemorphMUSH.mcl" file (or whatever you called the file), and rename the copy to a name that contains your character's name, such as "PMM_Rocky".
  3. Start up MUSHclient, then click "File", then "Open World..." and open the world file you just created in the previous step. If it automatically connected, disconnect by clicking "Connection", then "Disconnect".
  4. Click "File", then "World Properties...", which will open the Configuration window.
  5. Click the IP Address leaf under the General branch in the tree menu on the left, and then change the World Name to something involving your character's name, such as "PMM Rocky".
  6. Click the Connection leaf under the General branch in the tree menu on the left, and then enter your character's Name and Password and select "MUSH/MOO (CONNECT name password)" from the Connect drop down menu.
  7. Click the "OK" button to close the Configuration window
  8. Click "File", then "Save World Details" to save the world.

Now you will be able to connect as that character after starting MUSHclient by clicking "File", then "Open World...", and then selecting the world file named after your character, such as "PMM_Rocky.mcl", and then clicking "Connection", then "Connect" if it didn't connect automatically. This is much more convenient than having to enter something like "connect Rocky <password>" every time you connect to the mush, and allows you to be logged on as more than one character at once if you have more than one character.

Asking for Roleplay

Main article: Asking for Roleplay

As previously mentioned, we have a channel especially made for asking. However, there are many who prefer to ask over public channel (which is acceptable, but not the most effective means), or to page other players in hopes of snagging someone with interest. Please be aware that many of us may be on the MUSH for idle socializing while multitasking and may not always be available for roleplay. Most do not mind if you ask, however; we simply ask that you respect our answer in return, be it a yes or no.

Logging Your Roleplay Sessions

When you do find someone to roleplay with, you might want to save a record of your roleplay for various reasons, such as for learning new level-up attacks or just saving it for posterity. Ideally, you'll want to start logging before the roleplaying begins and then stop logging after it has ended or paused for whatever reason. There are ways to record your RP into a text file as it happens, which vary by client. These instructions assume you have already started up your client and logged into Pokemorph MUSH as the character you'll be roleplaying as, and you've already made all the necessary preparations with those you'll be roleplaying with.

On PotatoMU

  1. Click "Logging", then "Show Log Window", which will open up the Log dialog.
  2. If you've already started roleplaying and you haven't started logging yet, make sure the "Include Buffer From:" drop-down is set to "Main Window".
  3. If you're logging a roleplay session that was paused earlier and/or you've selected an already existing log file, be sure that the "Append to File?" Option is checked so you don't lose existing log data.
  4. Click the "..." button to open a file dialog for creating a new log file or opening an existing one. Be sure to give it a meaningful name, which should include your character's name and a title that describes the situation, such as "Rocky_and_Fault_meet_at_South_Beach.txt", and put it in a relevant folder you can easily access, preferrably one you've dedicated to storing logs of roleplays on Pokemorph MUSH.
  5. Once you've finished selecting the text file for the log and selecting the appropriate options, click the "Log" button, which will close the dialog and start writing text you receive (and possibly have already received if you've included the buffer in Step 2).
  6. When your roleplay session is finished, click "Logging"->"Stop Logging", then the name of the file you created or opened in Step 4.

If you want a global log for the Pokemorph MUSH world and your specific character created in the Adding Characters to Your PotatoMU Client that records all the text your receive from the mush, follow all the steps above for creating a log file, except the last one, and make sure both the "Leave Log Open?" and "Append to File?" options are checked, which will cause PotatoMU to keep writing to that file every time you start it up, open the Pokemorph MUSH world and specific character.

The "Show Timestamps?" option also writes timestamps to the log file in front of each line, and the format of these timestamps is the same as the clock displayed down at the bottom of the client, except between two brackets. This format can be changed by clicking "Options"->"Configure Program Settings", and then clicking "Program Settings"->"Misc Settings" in the tree menu on the left of the dialog, and changing what's in the "Clock Format" text box on the right of the dialog, and clicking the "OK" button on the dialog.

On MUSHclient

  1. Click "File", then "Log Session...", which opens the Log game session dialog.
  2. If you've already started roleplaying and you haven't started logging yet, don't change the number of included "lines from screen buffer in log file". Otherwise, set it to zero or a number less than its initial value to exclude from the log lines you've already received from the mush.
  3. Make sure that the "Log Output" box is checked so that you actually record the text you receive from the mush. Check "Log Commands" to also log the commands you send to the mush from the input field of the client.
  4. If you're writing to a log file you've saved from a previous roleplaying session that was paused, make sure that "Append to existing log file" is checked, or else you'll lose existing log data in the file.
  5. Fill in any comments you'd like added to the top of the log file (or the start of where it's appended) to the comment text box, such as a short description of the roleplay situation, a list of characters involved, etc.
  6. Click the "OK" button to open a file dialog for creating a new log file or opening an existing one. Be sure to give it a meaningful name, which should include your character's name and a title that describes the situation, such as "Rocky_and_Fault_meet_at_South_Beach.txt", and put it in a relevant folder you can easily access, preferrably one you've dedicated to storing logs of roleplays on Pokemorph MUSH.
  7. When your roleplay session is finished, click "File", then click "Log Session..." again (which will have a checkmark next to it to indicate that it is currently logging), then click "OK" in the prompt that appears to stop writing the log to the file.

Additional options for the log, such as the format of the log file data, what is written to the log, preambles and postambles for the files and individual lines (including timestamps), and an optional automatic log file, and much more are available by clicking "File", then "World Properties...", then clicking the Logging leaf under the General branch in the tree menu on the left of the dialog. These options will affect all log files you create for that world/character, and can be saved between client restarts by clicking "File", then "Save World Details" after changing them in the Configuration dialog and clicking "OK".